The Official NPPAngband And NPPMoria Forum

You are not logged in.


November 28, 2016 - NPPAngband forum has been migrated to a new host. SSL has been enabled so please use https:// if possible.

#1 2015-03-24 06:06:34

Registered: 2015-03-24
Posts: 2

NPPAngband-7.1 compilation errors

I'm trying to install NPPAngband on Manjaro Linux

I did the following:

./configure --with-no-install
And "make" ended with errors:

Makefile:5: *** missing separator.  Stop.
../mk/ recipe for target 'subdirs' failed
make[3]: *** [subdirs] Error 1
../mk/ recipe for target 'all' failed
make[2]: *** [all] Error 1
mk/ recipe for target 'subdirs' failed
make[1]: *** [subdirs] Error 1
mk/ recipe for target 'all' failed
make: *** [all] Error 1

Are those errors can be fixed by common user?


#2 2015-03-24 09:51:11

NPPAngband Maintainer
Registered: 2004-07-01
Posts: 1,647

Re: NPPAngband-7.1 compilation errors

Hi.  Which version of NPPAngband?  Is it the new QT Port beta, or the last stable version (7.1.0)?

If it is the new QT port, the only way to compile is to download QT.  I hope to eventually get a release package on LINUX for NPP that can be downloaded, but it is a ways off.

This link below contains instructions for compiling on debian-based Linux systems, so IN THEORY they should be helpful for Manjaro.  I don't think compiling NPP on Arch Linux systems has been specifically addressed in these forums yet.

Please let me know how it goes.  I will try to provide help if I can.


#3 2015-03-25 11:54:05

Registered: 2015-03-24
Posts: 2

Re: NPPAngband-7.1 compilation errors

Thanks for the answer.
This is last stable version npp-7.1.0-src
I found the same solution for Debian, but I don't know the names of corresponding packages in Arch. I hoped program will complain about missing dependencies or they will work with what I already have smile

I downloaded and started it in wine.


Board footer

Powered by FluxBB