The Official NPPAngband And NPPMoria Forum

You are not logged in.


July 4th, 2018 - Registrations have been turned off due to the large ratio of spam vs legitimate discussion.

#1 2016-02-21 14:35:24

Registered: 2016-02-21
Posts: 2

NPP-Angband 8.0.2 QPointer not found

Hi, I'm try to install NPP on elementary OS, a Linux distro based on Ubuntu.
When I run make after qmake, I get the following error message:

In file included from src/object_dialog.cpp:12:0:
./src/object_select.h:12:20: fatal error: QPOinter: No such file or directory
#include <QPOinter>
compilation terminated.
make: ** [object_dialog.o] Erro 1

Any thoughts on how to solve this?


#2 2016-02-21 19:48:39

NPPAngband Maintainer
Registered: 2004-07-01
Posts: 1,647

Re: NPP-Angband 8.0.2 QPointer not found

It is an errant capitalization.  Change the 'O' in QPOinter to a lowercase 'o' (should be: QPointer)

Interesting that error doesn't come up on either mac or windows.

I have only done a little playtesting on Linux.  The game works but there are bound to be some quirks on each operating systems.  Please let me know how it goes.


#3 2016-02-21 20:17:09

Registered: 2016-02-21
Posts: 2

Re: NPP-Angband 8.0.2 QPointer not found

It worked! Thanks a lot!
I must admit that it never occurred to me actually change the source code, even though it should be pretty obvious that it was not supposed to be QPOinter.
About the game itself, I don't know how it is on other OS's, but the interface is a little quirky, mainly due to the fact that the windows don't automatically fit to the size of the content. Of course this is not a terrible issue, and the game runs neatly in every other aspect that I've noticed.
Anyway, thanks again for the help! I'm glad I'll be able to finally play NPP!


Board footer

Powered by FluxBB